Review Board 1.7.22


Adding review request for https://issues.apache.org/jira/browse/HIVE-3559

Review Request #9248 - Created Feb. 1, 2013 and updated

Arun A K
Reviewers
hive
hive-git
Patch attached for https://issues.apache.org/jira/browse/HIVE-3559
Test cases added, https://issues.apache.org/jira/browse/HIVE-3559 
    udf_right.q
    udf_right.q.out

Total:
2
Open:
2
Resolved:
0
Dropped:
0
Status:
From:
Posted (Feb. 1, 2013, 9:51 p.m.)

   

  
It would be good to implement left() in this patch since the extra code required is virtually identical to what you have already written.

Also, is it possible to change the name to "right()", or does that cause problems with the parser?
Please add tests for the following cases:

* string parameter is NULL
* length parameter is NULL
* length parameter is 0
* length parameter is greater than the length of the string
* length parameter is negative

Note that in every case the correct behavior is whatever MySQL's version of right() does.