You must log in to post
Please turn it on in your browser preferences.
for specific sites, we recommend the
Review Request #2017 -
Created Sept. 22, 2011 and submitted
Oct. 25, 2011, 7:12 a.m.
Looks good; the code is much improved. However please note important change regarding ZOOKEEPER-1195.
Good point: "credentials" should be final.
More concise, good.
See https://issues.apache.org/jira/browse/ZOOKEEPER-1195 : this should be kerberosName.getHostName(), not kerberosName.getServiceName().
+1, thanks Thomas.