Review Board 1.7.22


FLUME-2049: Compile Flume with elasticsearch 0.90.1

Review Request #11581 - Created May 31, 2013 and updated

Edward Sargisson
flume-2049
Reviewers
Flume
flume-git
Compiles Flume with elasticsearch 0.90.1.
Previously Flume compiled with 0.19 - there was an api change in elasticsearch in 0.20 that requires a re-compie.
This change brings us up with the latest.
mvn verify passes.

Diff revision 1 (Latest)

  1. pom.xml: Loading...
pom.xml
Revision 9982f5d New Change
[20] 44 lines
[+20]
45
    <test.include.pattern>**/Test*.java</test.include.pattern>
45
    <test.include.pattern>**/Test*.java</test.include.pattern>
46
    <siteUrlDeployment>file://people.apache.org/www/incubator.apache.org/flume</siteUrlDeployment>
46
    <siteUrlDeployment>file://people.apache.org/www/incubator.apache.org/flume</siteUrlDeployment>
47
    <stagingDirectory>${project.basedir}/target/docs</stagingDirectory>
47
    <stagingDirectory>${project.basedir}/target/docs</stagingDirectory>
48

    
   
48

   
49
    <avro.version>1.7.3</avro.version>
49
    <avro.version>1.7.3</avro.version>
50

    
   
50
    <elasticsearch.version>0.90.1</elasticsearch.version>
51
  </properties>
51
  </properties>
52

    
   
52

   
53
  <modules>
53
  <modules>
54
    <module>flume-ng-core</module>
54
    <module>flume-ng-core</module>
55
    <module>flume-ng-configuration</module>
55
    <module>flume-ng-configuration</module>
[+20] [20] 791 lines
[+20]
847
      </dependency>
847
      </dependency>
848

    
   
848

   
849
      <dependency>
849
      <dependency>
850
        <groupId>org.elasticsearch</groupId>
850
        <groupId>org.elasticsearch</groupId>
851
        <artifactId>elasticsearch</artifactId>
851
        <artifactId>elasticsearch</artifactId>
852
        <version>0.19.10</version>
852
        <version>${elasticsearch.version}</version>
853
        <optional>true</optional>
853
        <optional>true</optional>
854
      </dependency>
854
      </dependency>
855

    
   
855

   
856
      <dependency>
856
      <dependency>
857
        <groupId>org.elasticsearch</groupId>
857
        <groupId>org.elasticsearch</groupId>
858
        <artifactId>elasticsearch</artifactId>
858
        <artifactId>elasticsearch</artifactId>
859
        <version>0.19.10</version>
859
        <version>${elasticsearch.version}</version>
860
        <classifier>tests</classifier>
860
        <classifier>tests</classifier>
861
        <scope>test</scope>
861
        <scope>test</scope>
862
      </dependency>
862
      </dependency>
863

    
   
863

   
864
      <dependency>
864
      <dependency>
[+20] [20] 212 lines
  1. pom.xml: Loading...