Review Board 1.7.22


Refactor physical operators to remove methods parameters that are always null

Review Request #11203 - Created May 16, 2013 and updated

Julien Le Dem
PIG-3307
Reviewers
pig
billgraham, cheolsoo, daijy, dvryaboy
pig-git
Refactor physical operators to remove methods parameters that are always null
test-commit
Total:
3
Open:
0
Resolved:
3
Dropped:
0
Status:
From:
Ship it!
Posted (May 17, 2013, 3:12 p.m.)
Looks good to me. I only have minor comments as below. Do you mind fixing them when you commit?

I also confirmed that all unit tests pass.
Can you fix indentation here?
  1. That because I generated the patch ignoring whitespace to make it more readable.
    I will commit with correct indentation
Can you fix indentation here?
This isn't what you introduced, but I think this is incorrect.

Shouldn't "in.getNextBigDecimal()" be "in.getNextBigInteger()" since we're casting BI to BD here?
  1. Yep, looks like a bug. Good catch!