Review Board 1.7.22


Enforce minmum ant version required in build script

Review Request #11031 - Created May 9, 2013 and updated

Arup Malakar
trunk
HIVE-4530
Reviewers
hive
hive-git
Enforce minmum ant version required in build script

 

Diff revision 1 (Latest)

  1. build.xml: Loading...
build.xml
Revision f1a03df157e889e732f948f83f4c1dc0812146ef New Change
[20] 56 lines
[+20]
57
  <property name="checkstyle.conf.dir" location="${hive.root}/checkstyle"/>
57
  <property name="checkstyle.conf.dir" location="${hive.root}/checkstyle"/>
58
  <property name="checkstyle.build.dir" location="${build.dir.hive}/checkstyle"/>
58
  <property name="checkstyle.build.dir" location="${build.dir.hive}/checkstyle"/>
59
  <property name="rat.build.dir" location="${build.dir.hive}/rat"/>
59
  <property name="rat.build.dir" location="${build.dir.hive}/rat"/>
60
  <property name="md5sum.format" value="{0}  {1}"/>
60
  <property name="md5sum.format" value="{0}  {1}"/>
61

    
   
61

   

    
   
62
  <!-- Check minimum ant version required -->

    
   
63
  <fail message="Please use ant version 1.8.0 or greater for building hive.">

    
   
64
    <condition>

    
   
65
      <not>

    
   
66
        <antversion atleast="1.8.0"/>

    
   
67
      </not>

    
   
68
    </condition>

    
   
69
  </fail>
62

    
   
70

   
63
  <condition property="is-offline" value="true" else="false">
71
  <condition property="is-offline" value="true" else="false">
64
    <isset property="offline"/>
72
    <isset property="offline"/>
65
  </condition>
73
  </condition>
66

    
   
74

   
[+20] [20] 1320 lines
  1. build.xml: Loading...